首页 » Java » IDEA提示Multi-catches are not supported at this language level的解决办法

IDEA提示Multi-catches are not supported at this language level的解决办法

原文 http://blog.csdn.net/yaogebeizhan/article/details/78053557

2017-09-21 17:20:23阅读(317)

使用IDEA创建的java项目,在使用如下代码时IDEA提示Multi-catches are not supported at this language level

try {
    ......
} catch (ClassNotFoundException | NoSuchMethodException e) {
    e.printStackTrace();
}

原因:
IDEA Maven项目默认的编译器bytecode是1.5,此版本编译器是java5,而Multi-catches是在java7才开始支持的,所以IDEA提示不支持。官方宣布的原因:

Apache Maven Compiler Plugin
The Compiler Plugin is used to compile the sources of your project. Since 3.0, the default compiler is javax.tools.JavaCompiler (if you are using java 1.6) and is used to compile Java sources. If you want to force the plugin using javac, you must configure the plugin option forceJavacCompilerUse.
Also note that at present the default source setting is 1.5 and the default target setting is 1.5, independently of the JDK you run Maven with. If you want to change these defaults, you should set source and target as described in Setting the -source and -target of the Java Compiler. 
See http://maven.apache.org/plugins/maven-compiler-plugin/examples/set-compiler-source-and-target.html.

解决方式:
一、在pom.xml中增加

<plugin>
    <groupId>org.apache.maven.plugins</groupId>
    <artifactId>maven-compiler-plugin</artifactId>
    <version>2.3.2</version>
    <configuration>
        <source>1.8</source>
        <target>1.8</target>
    </configuration>
</plugin>

二、修改IDEA配置,默认就使用1.8版本
点击File -> Settings -> Build,Execution,Deployment -> Compiler -> Java Compiler
Project bytecode version下拉框选择1.8。
该选项不会生效,因maven项目并没有使用此处指定的编译器。

最新发布

CentOS专题

关于本站

5ibc.net旗下博客站精品博文小部分原创、大部分从互联网收集整理。尊重作者版权、传播精品博文,让更多编程爱好者知晓!

小提示

按 Ctrl+D 键,
把本文加入收藏夹