首页 » Ruby » ERROR: Error installing redis redis requires Ruby version >= 2.2.2.

ERROR: Error installing redis redis requires Ruby version >= 2.2.2.

原文 http://blog.csdn.net/Hello_World_QWP/article/details/78261618

2017-10-17 18:20:37阅读(225)


安装 redis 接口时异常 ,系统 Ruby 版本过低 ! 输入命令 " gem install redis " 出现 " Error:  Error installing redis redis requires Ruby version >= 2.2.2. " ,如下图:

ERROR:  Error installing redis redis requires Ruby version >= 2.2.2.


根据错误信息可知,Redis需要Ruby版本不能小于2.2.2版本,查看系统默认当前 ruby 版本,输入命令 " ruby -v " , 如下图:

ERROR:  Error installing redis redis requires Ruby version >= 2.2.2.

当前系统默认的 ruby 版本为 2.0.0 ,所以需要将 ruby 版本升级到 2.2.2 或以上,

解决办法:

修改Ruby到最新版本(我使用的环境都是最新的,所以我需要将版本跟新到最新的版本,最新的版本多少呢?我也不知道,都在RVM管理工具里面,那么RVM是什么呢?请往下看!)
我在Ruby官网上找到的,上面对RVM进行了简单的介绍:RVM是一个命令行工具,可以提供一个便捷的多版本Ruby环境的管理和切换。


1、RVM需要通过CRUL来进行下载,那么我们要先下载CUEL,CURL是什么呢,它是Linux下的文件传输工具,利用URL的规则在命令行下工作,输入命令 " yum install curl " 进行安装,如下图:

ERROR:  Error installing redis redis requires Ruby version >= 2.2.2.


2、使用curl安装rvm ,输入命令 " curl -L get.rvm.io | bash -s stable " 进行安装,如下图:

ERROR:  Error installing redis redis requires Ruby version >= 2.2.2.


3、使用source让当前shell读入路径为" /usr/local/rvm/scripts/rvm "(路径可以自定义)的shell文件并依次执行文件中的所有语句,并重新执行刚修改的初始化文件,使之立即生效,而不必注销并重新登录,
输入命令 "  source /usr/local/rvm/scripts/rvm " ,查看rvm中管理的所有ruby版本,
输入命令 " rvm list known " 进行查询,如下图:

ERROR:  Error installing redis redis requires Ruby version >= 2.2.2.


4、选择一个你喜欢的版本进行安装,但首先提醒一下,你所选择的版本不能低于 " 2.0.0 " 就可以了,输入命令 " rvm install 2.3.4 " 进行安装,如下图:

ERROR:  Error installing redis redis requires Ruby version >= 2.2.2.


5、使用刚才安装完成的Ruby版本,输入命令 " rvm use 2.3.4 " ,如下图:

ERROR:  Error installing redis redis requires Ruby version >= 2.2.2.


6、移除系统中默认的版本号,输入命令 " rvm remove 2.0.0 " 进行移除,如下图:

ERROR:  Error installing redis redis requires Ruby version >= 2.2.2.


7、为了保险起见还是要检查一下(我个人习惯),输入命令 " ruby --version " ,如下图:

ERROR:  Error installing redis redis requires Ruby version >= 2.2.2.


好了关于 Ruby 版本过低的问题已经解决了,现在可以去 《 安装 Redis 接口 》

尊敬的读者朋友,如果本博文对你有一定的帮助,那就请不要吝啬你的赞,我花费了时间、精力、工作经验来编写博文,也许你的一个不经意的点赞ERROR:  Error installing redis redis requires Ruby version >= 2.2.2.,将会成为我前进的动力!!!

歇后语:“共同学习,共同进步”,也希望大家多多关注CSND的IT社区。

最新发布

CentOS专题

关于本站

5ibc.net旗下博客站精品博文小部分原创、大部分从互联网收集整理。尊重作者版权、传播精品博文,让更多编程爱好者知晓!

小提示

按 Ctrl+D 键,
把本文加入收藏夹