首页 » Java » JAVA -- Java compiler level does not match the version of the installed Java pro

JAVA -- Java compiler level does not match the version of the installed Java pro

原文 http://blog.csdn.net/qq814965130/article/details/79256900

2018-02-06 02:00:11阅读(290)

问题描述:加载新的项目后报一个错误:

Java compiler leveldoes not match the version of the installed Java project facet.

 

问题分析:

java版本不匹配:FactedProject 中的Java 版本设定与项目的Java 版本设定不一致。

 

解决方案:

在当前项目上点右键,属性--ProjectFacets中,配置编译版本与java

compiler的版本一致。

1、选中项目后按下alt+enter组合键或者右键Project

| Properties | JavaCompiler(type filter text输入compiler可快速定位),如下图所示:

JAVA -- Java compiler level does not match the version of the installed Java pro

2、修改ProjectFacets的Java值,使之和Compiler compliance level相同:打开方式参考1,如下图:

 JAVA -- Java compiler level does not match the version of the installed Java pro



3.找到项目下的.settings(D:\execWork\workspace\ReportAndDataServices\.settings)中的org.eclipse.wst.common.project.facet.core.xml文档中的Java版本,将其修改一致,如图

JAVA -- Java compiler level does not match the version of the installed Java pro

最新发布

CentOS专题

关于本站

5ibc.net旗下博客站精品博文小部分原创、大部分从互联网收集整理。尊重作者版权、传播精品博文,让更多编程爱好者知晓!

小提示

按 Ctrl+D 键,
把本文加入收藏夹